Smarts AM: Incorrect OID returned from polling of 'ifOperStatus' object (.1.3.6.1.2.12.2.1.8)
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Smarts AM: Incorrect OID returned from polling of 'ifOperStatus' object (.1.3.6.1.2.12.2.1.8)

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Article ID: 303689

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Incorrect OID returned from Smarts IP Availability Manager polling of ifOperStatus object (.1.3.6.1.2.12.2.1.8)
The following entries are seen in the Smarts IP Availability Manager log files:

[17-Jul-2008 17:32:26+107ms EAT] t@47 DEVSTAT-SNMP-Poller polling #9
SNMP-W-EINVALIDMESSAGE-Received invalid message from SNMP agent 172.16.10.250,
    port 161
 SNMP-EGETRESPONSE-In response to Get(.1.3.6.1.2.1.2.2.1.8.92)
 SNMP-EWRONGOID-Wrong OID (.1.3.6.1.2.1.2.2.1.8.10612) instead of requested
    OID
 SNMP-EAGENTBUG-Agent violates protocol; ignoring response; in file
    "/work/whitecurrent/FOUNDATION-7.0.2.X-HF/18/smarts/snmp_accessor/snmp_ada
    ptor.c" at line 374



Environment

VMware Smart Assurance - SMARTS

Cause

The packet capture in the log file entry indicates that there is a mismatch between the OID polled and the value returned. Smarts polls the following as part of the varbind:

name: .1.3.6.1.2.1.2.2.1.8.92 (IF-MIB::ifOperStatus.92)

But the following value is returned:

name: .1.3.6.1.2.1.2.2.1.8.10612 (IF-MIB::ifOperStatus.10601)

Resolution

This is not a Smarts issue but an issue with the Cisco SNMP agent. Please contact Cisco support for assistance with this issue.