"Adding Mobility Agent Host failed. Cannot complete login due to an incorrect username or password"
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"Adding Mobility Agent Host failed. Cannot complete login due to an incorrect username or password"

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Article ID: 303663

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

- Redeploy of IX appliance fails with error

Adding Mobility Agent Host failed. Cannot complete login due to an incorrect user name or password.

Error Messages in vCenter "Recent Tasks"

Cannot complete login due to an incorrect user name or password.



Cause

The cause is actually likely related to a network configuration problem when you check the HCX logs
/common/logs/admin/app.log

2020-02-25 21:44:12.291 UTC [InterconnectService_SvcThread-11, IX:####-####-####-##########, J:####, , TxId: ####-####-####-##########] INFO  c.v.v.h.s.i.AppliancePostConfigJob- WAN-OPT login failed. Requeuing back. Re-try attempt 2
2020-02-25 21:44:16.246 UTC [VsphereReplicationService_SvcThread-329, Ent: HybridityAdmin, , TxId: ####-####-####-##########45] INFO  RCM- Cleaning the cache since 5
2020-02-25 21:45:16.259 UTC [VsphereReplicationService_SvcThread-341, Ent: HybridityAdmin, , TxId: ####-####-####-##########45] INFO  RCM- Cleaning the cache since 5
2020-02-25 21:45:17.375 UTC [InterconnectService_SvcThread-20, IX:####-####-####-##########, J:####, , TxId: ####-####-####-##########] ERROR c.v.v.h.a.gateway.GatewayAdapter- Exception while posting configuration to gateway.
org.apache.http.conn.ConnectTimeoutException: Connect to #.#.#.#:9443 [/#.#.#.#] failed: connect timed out
        at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:143)

Resolution

This is related to best practices of how to overcome the error message seen above

Validate and check the following

  • End user is able to log into HCX Enterprise Manager :9443 page via admin
  • Validate proper administrator privileges are applied to associated vCenter for HCX

Login to https://<on-premises.hcx.mgr.ip>:9443/ --> Select "Configuration" tab --> Select "vCenter" tab and ensure the user has administrative privileges

  • Ensure the user is able to log into vCenter and access the HCX plug-in in the vCenter UI (HTML5 client)


Once the above has been checked, then it will be best to check the network profile settings and ensure you have connectivity to your on-premises hosts from the HCX uplink network profile.

This is captured in our public documentation - 
HCX Manager User Account and Role Requirements

Then check:

  • That HCX manager is able to communicate with the Service Mesh Management IP (found in app.log)
  • Verify no wrong IP range in network profile
  • Verify no wrong Gateway in network profile
  • Verify no wrong subnet mask in network profile
  • Verify no wrong port group in network profile
  • Verify no firewall or routing problem between HCX Manager and the service mesh network (uplink)