Disaster Recovery (DR) Protection Removal
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Disaster Recovery (DR) Protection Removal

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Article ID: 303659

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

This KB outlines the procedure/instruction to manually remove DR Protection objects from the HCX Connector or Cloud Manager database and is applicable to DR Protections ONLY.

  • VR Bulk, Cold, vMotion, and RAV cannot be removed with this procedure.
  • Refer to HCX-Mobility Migration Removal for guidance on removing other mobility types.

The steps outlined below are helpful in the following scenarios

  • DR Protections configured through the HCX UI become non-actionable.
  • Data replication is no longer occurring to the target recovery site.
  • The option to Force Remove is unavailable, grayed out, or ineffective when run from the HCX Connector or Cloud Manager.
  • A new DR Protection cannot be configured for the affected VM.

Environment

VMware HCX
VMware Cloud on AWS

Cause

The causes for a disruption of a DR protection or for one to become non-actionable vary, and in most cases are unrelated to HCX.

Resolution

The resolution requires cleaning up entries in the HCX Database. Recommendations are as follows

  1. Take a backup of the HCX Manager for both the HCX Connector (Source) and the HCX Cloud (Target).
  2. Make a note of the replicationId for the stuck or failed HCX DR task.
    • Example: HRID-e3afdbca-####-#####-eaacb2######
  3. Contact Broadcom Support for the HCX DB cleanup commands. Broadcom Support will assist with the removal of stale tasks from the HCX DB after reviewing the issue.