Conflicts detected after a compliance check on the ESX/ESXi host using Update Manager
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Conflicts detected after a compliance check on the ESX/ESXi host using Update Manager

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Article ID: 303654

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
When scanning an ESX/ESXi host using Update Manager against a dynamic or static baseline that includes multiple security bulletins:

  • The scan detects multiple conflict patches with an exclamation symbol.
  • You see this error:

    The selected update conflicts with the following updates in the VMware vCenter Update Manager patch repository


Environment

VMware ESXi 4.1.x Embedded
VMware vCenter Server 5.0.x
VMware ESXi 4.1.x Installable
VMware ESX 4.1.x
VMware vCenter Server 4.1.x
VMware vCenter Update Manager 4.0.x
VMware vCenter Update Manager 4.1.x
VMware vSphere ESXi 5.0
VMware vCenter Update Manager 5.1.x
VMware vCenter Update Manager 5.0.x
VMware vCenter Server 4.0.x
VMware ESXi 4.0.x Embedded
VMware vSphere ESXi 5.1
VMware ESX 4.0.x
VMware ESXi 4.0.x Installable
VMware vCenter Server 5.1.x

Resolution

Cause


This issue may occur if:
  • An update in the baseline conflicts with either other updates in the Update Manager patch repository or an existing update on the host.

    Note: This does not affect the functionality and the error can be safely ignored

  • The version of vCenter Server is older than that of the ESX/ESXi host. For example, you are using vCenter Server 4.0 and ESXi 4.1.


Resolution

To work around this issue, detach or edit the baseline containing the update that conflicts with another update that is already installed on the host.

To edit the baseline:
  1. In the Baselines and Groups tab, click Hosts.
  2. S elect a patch baseline and click Edit above the Baselines pane.
  3. Edit the name and description of the baseline and click Next.
  4. Go through the Edit Baseline wizard to change the criteria and select the patches to include or exclude.
  5. In the Ready to Complete page, click Finish.
To detach the baseline:
  1. Connect the vSphere Client to a vCenter Server system with which Update Manager is registered.
  2. Click Home > Inventory.
  3. Select the type of object from which you want to detach the baseline or group.
  4. Select the object in the inventory and click the Update Manager tab.
  5. Right-click the baseline or baseline group to remove and click Detach Baseline or Detach Baseline Group.
  6. Select the inventory objects from which you want to detach the baseline or baseline group and click Detach.

To remove the baseline:
  1. In the Baselines pane of the Baselines and Groups tab, select the baselines to remove.
  2. Click Delete.
  3. In the confirmation dialog, click Yes.




Additional Information

For more information, see Compliance States for Updates.