VoyenceControl: Jobs and tasks stuck in "queued for execution" state
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Article ID: 303583
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Jobs and tasks stuck in "queued for execution" state.
"Pull after cut-thru"-type jobs are stuck in "queued for execution" state.
"Pull after Syslog"-type jobs are stuck in "queued for execution" state.
Environment
VMware Smart Assurance - NCM
Cause
The task numbers for cmd files created by the Healthcheck service are shorter than regular pull/push task numbers. When unlinking the tasks for the Healthcheck it is possible to match a portion of other pull/push task numbers, accidentally removing those task files before they are started. Those push/pull tasks are abandoned.
Resolution
The Healthcheck PERL script requires a slight modification to give it's task files unique task numbers:
On the Application server, change to the Voyence Healthcheck directory as follows: cd $Voyence_HOME/Healthcheck
Open the healthcheck.pl file for editing and locate the following line on or about line 97: