VoyenceControl: How do I change the password VCCRM uses to access VoyenceControl?
book
Article ID: 303582
calendar_today
Updated On:
Products
VMware
Issue/Introduction
Symptoms:
How do I change the password VCCRM uses to access VoyenceControl?
You are unable to login to the VoyenceControl Compliance Report Manager user interface at http:// ServerIP :8080 / VoyenceReporting
Environment
VMware Smart Assurance - NCM
Cause
You installed VCCRM using a VoyenceControl user account and the password was changed on this account in VoyenceControl
Resolution
- Login to your reporting/application server as root
- cd /usr/tomcat/jakarta-tomcat-3.3.2/webapps/VoyenceReporting/WEB-INF/classes/
- source /etc/voyence.conf
- java -cp ../lib/JR_VC_common.jar com.voyence.reporting.auth.CryptoHelper NewPasswordHere
- Copy the hash value that is returned when running the above command
- vi config.properties
- Go to line 21 where it says "reporting.adminPass="
- Remove the current hash value after the equals sign
- Paste in the new has value that you created in step 4
- Save and quit the file
- Restart the tomcat service:
/etc/init.d/tomcat stop
/etc/init.d/tomcat start
Additional Information
NewPasswordHere refers to the password that was set in VoyenceControl
Feedback
thumb_up
Yes
thumb_down
No