Smarts NCM: Status for running job shows as "queued", but no progress is made
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Smarts NCM: Status for running job shows as "queued", but no progress is made

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Article ID: 303569

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Status for job running in Smarts Network Configuration Manager (Smarts NCM) shows as "queued", but no progress is made
Messages similar to the following are seen in the syssyncs.log on the Smarts NCM Application Server:

 Line 4059: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "HTTP/1.1 400 Server Busy"
 Line 4060: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "Date: Wed, 23 Jan 2013 17:04:31 GMT"
 Line 4061: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "Server: Apache"
 Line 4062: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "Content-Length: 0"
 Line 4063: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "Connection: close"
 Line 4064: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: "Content-Type: text/plain; charset=UTF-8"
 Line 4065: Jan 23 11:04:32 -1258591328/status_0113589606190000#7: recv: ""
 Line 4066: Jan 23 11:04:32 -1258591328/status_0113589606190000#2: ...getRespHeaders: end
 Line 4067: Jan 23 11:04:32 -1258591328/status_0113589606190000#4: Checking Redirect location
 Line 4068: Jan 23 11:04:32 -1258591328/status_0113589606190000#2: Send complete
 Line 4069: Jan 23 11:04:32 -1258591328/status_0113589606190000#1: HTTP send failed, Code:400
 
 
HTTP send failed, Code:400 means  'The request cannot be fulfilled due to bad syntax'

 

Messages in the following pattern are repeatedly seen in the syssyncm.log on the Smarts NCM Application Server:

Jan 23 12:34:49 -1437647968/status_0113563739790000#7: recv: "Content-Type: text/plain; charset=UTF-8"
Jan 23 12:34:49 -1437647968/status_0113563739790000#7: recv: ""
Jan 23 12:34:49 -1437647968/status_0113563739790000#2: ...getRespHeaders: end
Jan 23 12:34:49 -1437647968/status_0113563739790000#4: Checking Redirect location
Jan 23 12:34:49 -1437647968/status_0113563739790000#2: Send complete
Jan 23 12:34:49 -1437647968#7: Disconnecting...
Jan 23 12:34:49 -1437647968#5: Shutting down SSL connection...
Jan 23 12:34:49 -1437647968#7: SSL Write Alert: 256
Jan 23 12:34:49 -1437647968#7: SSL State: warning-SSL negotiation finished successfully
Jan 23 12:34:49 -1437647968#7: SSL Read Alert: 256
Jan 23 12:34:49 -1437647968#7: SSL State: warning-SSL negotiation finished successfully
Jan 23 12:34:49 -1437647968#5: Freeing SSL connection...
Jan 23 12:34:49 -1437647968#5: SSL connection shutdown
Jan 23 12:34:49 -1437647968#7: Connection closed



When running a job in Smarts NCM, the status will show as queued, but no progress will be made.

Environment

VMware Smart Assurance - NCM

Cause

This issue occurs because the Smarts NCM Application Server cannot connect to device server. The underlying cause that the self signed certificate (or CA) was copied and moved to the device server from the application server using a non preferred method. Using the ./makekeys.sh utility in the /bin directory on the Smarts NCM device server is the preferred method of placing the certificate on the device server.

Resolution

If you encounter this issue, do the following on the Smarts NCM device server:
  1. Go to the $NCM_Home/conf/CA directory and change the current voyenceca.crt to voyenceca.crt.old.
  2. Go to the $NCM_Home/bin directory and run the ./makekeys.sh utility to provide a new certificate.
  3. Restart services on the device server as follows:


    cd $NCM_Home/conf/CA
    mv voyenceca.crt voyenceca.crt.old
    cd $NCM_Home/bin
    ./makekeys.sh
    service vcmaster restart

     
  4. Run a job for that device server to test communication.