Smarts NCM: Receive "Keystore was tampered with, or password was incorrect" error during WebServer deployment; Cannot log into Smarts NCM after installing SSL certificate
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Smarts NCM: Receive "Keystore was tampered with, or password was incorrect" error during WebServer deployment; Cannot log into Smarts NCM after installing SSL certificate

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Article ID: 303565

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Receive "Keystore was tampered with, or password was incorrect" error during Smarts Network Configuration Manager (Smarts NCM) WebServer deployment
Cannot log into Smarts NCM after installing SSL certificate

Updating a third-party certificate and generating the Java keystore prevents NCM login

Deployment "WebServer" is in error due to the following reason: LifecycleException: Protocol handler initialization failed: java.io.IOException: Keystore was tampered with, or password was incorrect

Deployment "jboss.webervice=WebServer" is in error due to the following reason: ** NOT FOUND Depends on 'jboss.webervice=WebServer' **

Environment

VMware Smart Assurance - NCM

Cause

The above issues will occur if the keystore value in the jboss server.xml does not get updated from the passphrase response, which will result in a mismatch.

Resolution

Do the following to verify if this there is a mismatch:

  1. Check the keystorePass= value from jboss/server/vc-server/deploy/jbossweb.sar/server.xml.
  2. Run the the following command:  $JAVA_HOME/bin/keytool -list -keystore path (This command to list checksums and aliases).
  3. Enter in password found from the server.xml. (If you have the wrong password, it gives the error "Keystore was tampered with, or password was incorrect").

Once you verify there is a mismatch now make the following changes:

  1. Modify the server.xml keystorePass= with the correct keystore passphrase and save.
  2. Restart NCM services.
  3. Verify the connection to the Smarts NCM console.