Voyence: Installing Smarts Integration Adapter for VoyenceControl 4.0.1
search cancel

Voyence: Installing Smarts Integration Adapter for VoyenceControl 4.0.1

book

Article ID: 303545

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:


Where should the Smarts Integration Adapter be installed for VoyenceControl 4.0.1?

Smarts Adapter cannot connect to other Applications
Map View of the topology not working correctly

Environment

VMware Smart Assurance - NCM

Cause

Smarts Integration Adapter installed on the same server as the VoyenceControl Tomcat instance

Resolution

Solution 1 (Separate Report Advisor and Voyence Control Deployment) The best solution is to install Report Advisor on a separate physical server than Voyence Control. The integration adaptor and the Report Advisor product conflict inside Tomcat similar to the issue reported above.   In installations with more than a trivial amount of devices, this is the recommended deployment of Voyence Control and Report Advisor anyway.   Then deploy the integration adaptor on the Voyence Control system.

Solution 2 (Separate Server)

If Voyence Control and Report Advisor are on the same server, the adaptor can be installed on a separate (3rd) server.