Smarts NCM: Interface is running slow and becomes unresponsive; Navigating and executing tasks within the Smarts NCM interface takes a very long time and sometimes fails
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Article ID: 303536
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Smarts Network Configuration Manager (Smarts NCM) interface is running slow and becomes unresponsive Navigating and executing tasks within the Smarts NCM interface takes a very long time and sometimes fails
Environment
VMware Smart Assurance - NCM
Cause
This issue can occur because of a memory issue on the client or the server.
Resolution
Check that behavior is the same on other client machines. If the performance issue is only on observed one client, the memory issue must be addressed on that client, perhaps by closing open programs. If the performance issue is the same on other client machines, you can increase the memory available to JBOSS on the server as follows:
Navigate to /etc/ directory.
Edit the jboss.conf file.
Look for the JAVA_OPTS= line.
Find the -Xms4096M -Xmx4096M section.
Change -Xmx to a higher amount depending on the amount of RAM on the system (see Note statement).
Save file.
Restart vcmaster service:
service vcmaster restart
Additional Information
The maximum amount to put in for Xmx will vary depending on the total amount of RAM available to the operating system. Make small incremental changes to this variable until the performance is improved. It is not advisable to increase this variable to more than one-quarter of the physical RAM available to the Server.