Smarts NCM: ControlDaemon service is in a restart loop and will not start
search cancel

Smarts NCM: ControlDaemon service is in a restart loop and will not start

book

Article ID: 303533

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Smarts Network Configuration Manager (Smarts NCM) ControlDaemon service is in a restart loop
Smarts NCM ControlDaemon service will not start

The following errors in the daemon.log for the Smarts NCM environment:

(main) Exception in Device Services Daemon
java.lang.IllegalArgumentException: Invalid IP Address [null]



The following errors in the server.log for the Smarts NCM environment:

class com.powerup.common.CMSystemException:Unable to communicate with DeviceManagementService (please check if ControlDaemon is running...)



Environment

VMware Smart Assurance - NCM

Cause

No IP address is found for the device server listed.

Resolution

If you encounter this issue, follow the instructions in 10898 to modify the Smarts NCM (formerly VoyenceControl) cflist.cgi and .rhttps files.