VoyenceControl 4.0: Receive an error when trying to update a job using the API
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VoyenceControl 4.0: Receive an error when trying to update a job using the API

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Article ID: 303529

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


How do I update a job using the API?

Program fails at the call to ApiService.updateJob().
Program throws an ApiBusinessException.

The server.log reports two errors:

2008-07-31 14:48:25,088 ERROR [com.powerup.configmgr.server.services.scheduler.impl.SchedulerDataStore] (http-0.0.0.0-8881-69) Failed update job JobName1 - job updater  not found
2008-07-31 14:48:25,088 ERROR [com.powerup.configmgr.server.services.scheduler.ejb.SchedulerServiceBean] (http-0.0.0.0-8881-69) Failed to update job
class com.powerup.common.CMSystemException:generalExceptions.userNotFound



Environment

VMware Smart Assurance - NCM

Cause

The setUpdatedBy() method has not been called on the JobInfo object.  When updating a job, this value needs to be populated with a valid user login name.

Resolution

Programs must call the setUpdatedBy() method on the JobInfo object.  The value supplied must be a valid user login name.