Smarts NCM: Report Advisor is not accessible after crash/service restart/system reboot
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Smarts NCM: Report Advisor is not accessible after crash/service restart/system reboot

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Article ID: 303523

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Smarts Network Configuration Manager (Smarts NCM) Report Advisor interface is not accessible after crashing
Cannot access Smarts NCM Report Advisor after a crash

Cannot access Smarts NCM Report Advisor after a restart of services or a reboot of the system

Smarts NCM Report Advisor will not start after a restart of services or a reboot of the system

Catalina.out file for the Smarts NCM installation located in /usr/tomcat/APACHE-TOMCAT-CURRENT_VERSION\logs contains the following error:

SEVERE: IOException while loading persisted sessions: java.io.EOFException



Environment

VMware Smart Assurance - NCM

Cause

The Catalina.out file SEVERE error indicates that tomcat is trying to reload an old session that was present before tomcat was restarted or system was rebooted. At times, this file can become corrupted during a crash and cannot be accessed by tomcat when it is restarting.

Resolution

The following steps can be taken to resolve this issue and regain access to Report Advisor: 

1.     Navigate to $CATALINA_HOME}/work/Catalina/localhost/web/
2.     Locate the file named 'SESSION.ser'
3.     Delete this file. IMPORTANT! Deleting this file will tell tomcat NOT to try and reload the last session. instead tomcat will create a new session.
4.     Restart tomcat service
5.     Try to access Report Advisor again.

At this point you should be able to access Report Advisor again.