Smarts NCM: Receive "Valid Credentials Found, but could not determine driver for device" error in auto discovery job results for SNMP discovery; How can I use telnet/SSH to discover a device with Smarts NCM?
search cancel

Smarts NCM: Receive "Valid Credentials Found, but could not determine driver for device" error in auto discovery job results for SNMP discovery; How can I use telnet/SSH to discover a device with Smarts NCM?

book

Article ID: 303515

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


How can I use telnet/SSH to discover a device with Smarts Network Configuration Manager (Smarts NCM)?

The following error is seen in the auto discovery job results and may be seen in autodisc.log file when trying to autodiscover and authenticate a device using only SNMP:

Valid Credentials Found, but could not determine driver for device Locating devices...done



Environment

VMware Smart Assurance - NCM

Cause

Device that needs to be discovered by Smarts NCM does not support SNMP discovery.

Resolution

Review the Smarts NCM Device Support matrix for the version and patch of Smarts NCM you are using to determine if your device supports Smarts NCM SNMP discovery. If your device does not support discovery by SNMP and you will need to use Telnet or SSH to discover the device. To do this, you will need the following:

  • Username and password for the account profile on the device used to discover the device
  • Privileged password for the device to do other tasks that require that password be entered, including configuration pushes and other administrative tasks

To allow Smarts NCM to discover your device using Telnet or SSH, do the following:

  1. Ensure that the device(s) you want to discover have Telnet/SSH setup and configured
  2. Ensure you have the correct credentials for discovering the device. This can be testedby using a 3rd party program to Telnet/SSH directly to the device.
  3. Once you are sure you have the proper credentials, set up an account within Smarts NCM with those credentials.
  4. Once you have an account with the proper device credentials, schedule an auto discovery job as follows:
     
    1. Go into Smarts NCM System administration, and select the network into which you want to discover the device.
    2. Select Auto Discovery Manager> Auto Discovery.
    3. Click Add to create a new job, or Edit if you want to change an existing job.
    4. Fill out Name, Device Server, and type under the property tabs.
    5. Fill in the appropriate IP (address range) information on the range tab.
    6. Select the Credential tab and click on Account.
    7. The account credential for the account you created should be listed under Available Credentials.
    8. Click the credential you want to use and click the Add button.
    9. The credential should now be listed on the right hand side under Assigned Credentials.
    10. If a Privilege Password Account is also needed, repeat the preceding steps that were done in the Credential on the Privilege Password tab.
    11. Click OK, and you should now be back on the Auto Discovery main page.
    12. Schedule the Auto Discovery job.

       
  5. The Auto Discovery job will run and use Telnet/SSH to discover the devices based on the mechanisms set up under your device classes.


Additional Information

For instructions on how to add a credential to Smarts NCM, see 17195 .