Smarts NCM/VoyenceControl Report Advisor hangs when big reports are run; How do I change the JDBC connection timeout value in Report Advisor?
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Smarts NCM/VoyenceControl Report Advisor hangs when big reports are run; How do I change the JDBC connection timeout value in Report Advisor?

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Article ID: 303489

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


How do I change JDBC connection timeout value in Smarts Network Configuration Manager (Smarts NCM)/VoyenceControl Report Advisor?

Smarts NCM/VoyenceControl Report Advisor hangs when big reports are run

Smarts NCM/VoyenceControl Report Advisor hangs when reports are run that return a large amount of result data



Environment

VMware Smart Assurance - NCM

Cause

Because of the amount of result data, a JDBC connection time out is happening

Resolution

To change/increase the JDBC connection timeout value and address the Report Advisor issue, do the following on the system where Report Advisor is installed:
  1. Back up the following file to a separate location:

    $VOYENCE_HOME/web/conf/web.properties

     
  2. Open the web.properties file in an appropriate editor.
  3. Find the following parameter:

    vcweb.c3p0.unreturned_connection_timeout=600

     
  4. Increase the parameter value from 600 (default) to a value large enough that will be expected to prevent the timeout issue, but not exceedingly large to cause performance issues (it may take a few attempts to find the correct value). 
  5. Save and close the web.properties file.
     
  6. Restart the tomcat service.