Report Advisor hangs when big reports are run; How do I change the JDBC connection timeout value in Report Advisor?
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Article ID: 303489
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
How do I change JDBC connection timeout value in Smarts Network Configuration Manager (Smarts NCM)/VoyenceControl Report Advisor?
Report Advisor hangs when big reports are run that return a large amount of result data.
Environment
NCM version until 9.6
Cause
Because of the amount of result data, a JDBC connection time out is happening
Resolution
Back up the following file to a separate location:
$VOYENCE_HOME/web/conf/web.properties
Open the web.properties file in an appropriate editor. Find the following parameter:
vcweb.c3p0.unreturned_connection_timeout=600
Increase the parameter value from 600 (default) to a value large enough that will be expected to prevent the timeout issue, but not exceedingly large to cause performance issues (it may take a few attempts to find the correct value).