Smarts NCM: Bulk import fails when attempting to import from CSV file
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Smarts NCM: Bulk import fails when attempting to import from CSV file

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Article ID: 303484

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Smarts Network Configuration Manager (Smarts NCM) bulk import fails when attempting to import from CSV file

Receive the following error message when trying to import from CSV file in Smarts NCM:

java.lang.NumberFormatException: For input string:  "DevicePkg



Environment

VMware Smart Assurance - NCM

Cause

When attempting to do a bulk import, the Smarts NCM import routine is looking only for an IP address and Fully Qualified Domain Name (FQDN).  If there is any other type of data such as a header line, it will fail.

Resolution

Remove any header lines from the CSV file and retry the import operation.