Smarts NCM: Receive "An unexpected problem has occurred. Please contact EMC Customer Support" popup message while running compliance audit on devices
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Smarts NCM: Receive "An unexpected problem has occurred. Please contact EMC Customer Support" popup message while running compliance audit on devices

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Article ID: 303471

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:



 

Receive the following popup message in Smarts Network Configuration Manager (Smarts NCM) console while running compliance audit on devices:

An unexpected problem has occurred. Please contact EMC Customer Support.


The following error is seen in the Smarts NCM server.log file ($VOYENCE_HOME/jboss/server/vc-server/log/server.log): 

Caused by: org.postgresql.util.PSQLException: ERROR: could not write to hash-join temporary file: No space left on device
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1548)



Environment

VMware Smart Assurance - NCM

Cause

The database has run out of storage because the disk space is full or not accessible.

Resolution

Confirm/ensure that your database server has enough accessible disk storage space. Once the lack of storage space has been resolved, the above issue should no longer occur.