Windows 7 virtual machine is unresponsive to RDP, but is accessible from the vSphere Client
search cancel

Windows 7 virtual machine is unresponsive to RDP, but is accessible from the vSphere Client

book

Article ID: 303452

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Cannot access the Windows 7 virtual machine through RDP
  • You see an error indicating that the virtual machine is unresponsive
  • When you ping the virtual machine, you do not get any response
  • You are able to access the virtual machine from the vSphere Client console


Environment

VMware vCenter Server 4.1.x
VMware vCenter Server 5.1.x
VMware vSphere ESXi 5.5
VMware vSphere ESXi 5.0
VMware vCenter Server 5.0.x
VMware vCenter Server 5.5.x
VMware vCenter Server 4.0.x
VMware vSphere ESXi 5.1
VMware ESXi 4.1.x Installable

Cause

This issue occurs when the Windows 7 power saving features are set to sleep and standby. The Windows 7 operating system is not aware that it is a virtual machine and goes into the power saving mode when it is inactive for a set period of time.

Resolution

To resolve this issue, change the power options on the virtual machine.
To change the power options on the virtual machine:
  1. Open a console session to the virtual machine.
  2. Click Start > Control Panel.
  3. Click Power Options.
  4. Under Control Panel Home, click Change when the computer sleeps.
  5. Set the Turn off the display option to Never.
  6. Set the Put the computer to sleep option to Never.

For more information, see Sleep and hibernation: frequently asked questions.

Note: The preceding link was correct as of June 29, 2012. If you find the link is broken, provide feedback and a VMware employee will update the link.