Skyline Collector Status: ‘Inactive’
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Skyline Collector Status: ‘Inactive’

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Article ID: 303441

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Updated On:

Products

VMware

Issue/Introduction

Message on Skyline Advisor: “Collector is inactive and health cannot be determined.”

Cause

The Skyline Collector is not collecting data. This issue is due to one of the following reasons:

  1. The Collector is in powered off State
  2. The Collector is not upgraded to the latest version
  3. The Collector has lost network configuration or unable to communicate to VAC (VMware Analytical Cloud)
  4. Connectivity with all endpoints has stopped working, due to any/all of:
    1. Endpoint password has expired
    2. Endpoint configuration is changed or certificate was updated
    3. Required permissions are not assigned
  5. Collector service is not running.

 

Resolution

  1. Check if the Collector virtual machine is Powered ON
  2. The Collector is not upgraded to the latest version
    1. Login to Skyline UI. 
    2. Find the notification banner in the Skyline Collector web interface
    3. On the notification banner, click UPGRADE
  1. The Collector has lost network configuration or unable to communicate to VAC (VMware Analytical Cloud)
    1. Using the vSphere Client, open the remote console of the Skyline Collector virtual appliance.
    2. Log in to the console of the Skyline Collector virtual appliance with user 'root'.
    3. Use this command to configure and validate the network configuration
      /opt/vmware/share/vami/vami_config_net
    4. Execute the below command to validate connectivity
      curl -v --proxy {PROXY_HOST}:{PROXY_PORT} --proxy-user user:password 
      https://vcsa.vmware.com
      • Note: Remove --proxy and --proxy-user sections if not relevant 
    5. Validate the communication status and the certificate status in the results. If needed Import a Proxy Server Certificate to VMware Skyline Collector Import a Proxy Server Certificate to VMware Skyline Collector ​​​​​​​
    6. Reboot the collector and validate again
  1. Follow the steps below to check if the Endpoint password has expired, or if the configuration is changed, or the certificate was updated.
    1. Login to the Skyline Collector UI by going to https://Skyline_VM_IPAddress
    2. Use the admin user credentials to log in
    3. Click on the ‘Configuration’ tab
    4. Click ‘edit’ next to the endpoint (vCenter, Horizon, vROps, NSX) depending on which issue is reported with Red exclamation
    5. Update the correct credentials

Note: If the user used has a password policy to expire the password, request to use an AD User and disable password expire for that User

    1. Save and update the certificate 
  1. Follow the steps below to resolve the collector service not running.
    1. Using the vSphere Client, open the remote console of the Skyline Collector virtual appliance. 
    2. Log in to the console of the Skyline Collector virtual appliance with user 'root'. 
    3. Check if collector server is running "systemctl status ccf-collector.service"
    4. If the collector service is not running then execute "systemctl start ccf-collector.service.
 
If the required permissions are not updated, follow the steps mentioned in VMware Skyline Log Assist Rights.

Additional Information

Skyline Collector Password Reset:
VMware Skyline Collector Password Reset