ifconfig -a
only the loopback lo0
network interface is shown. Guest vmxnet fast network device: done
The following interfaces will not be brought up automatically
because they do not have at least one corresponding config file:
- vmxnet3s0
Guest operating system daemon: done
The VMXNET3 network card not showing automatically is expected behavior. Solaris does not automatically configure a new network card which has been added to the virtual machine.
To configure the network card:
vmxnet3s
has been correctly added and loaded in the Solaris kernel. Check the system logs, to see if the driver loaded, by running this command:# grep -i vmxnet /var/adm/messages
sol10vm vmxnet3s: [ID 413941 kern.notice] vmxnet3s:0: attach()
sol10vm mac: [ID 469746 kern.info] NOTICE: vmxnet3s0 registered
sol10vm pcplusmp: [ID 272826 kern.info] pcplusmp: pci15ad,7b0 (vmxnet3s) instance 0 irq 0x32 vector 0x60 ioapic 0xff intin 0xff is bound to cpu 0
sol10vm vmxnet3s: [ID 377482 kern.notice] vmxnet3s:0: intrType=0x4, intrMaskMode=0x0, intrPrio=6
vmxnet3s0
has been registered in Solaris.vmxnet3s1
.# ls -l /dev/vmxnet3*
lrwxrwxrwx 1 root root 34 Jan 24 09:28 /dev/vmxnet3s -> ../devices/pseudo/clone@0:vmxnet3s
lrwxrwxrwx 1 root root 57 Jan 24 09:28 /dev/vmxnet3s0 -> ../devices/pci@0,0/pci15ad,7a0@15/pci15ad,7b0@0:vmxnet3s0
# ifconfig -a
vmxnet3s0
has not been activated, you can only see the loopback interface lo0
:lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
vmxnet3s0
:# ifconfig vmxnet3s0 plumb
ifconfig
:# ifconfig -a
lo0
and VMXNET3 vmxnet3s0
are configured:lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
vmxnet3s0: flags=1000842<BROADCAST,RUNNING,MULTICAST,IPv4> mtu 9000 index 2
inet 0.0.0.0 netmask 0
ether 0:c:29:7a:1b:bb
You see that a MAC/Ethernet address is assigned to the network card, but does not have an IP address or netmask configured. The network card is also not online, as the UP flag is not present.
Note: If you reboot the virtual machine, the vmxnet3s0
interface disappears again, as you have not configured any network information for it..
Note: Solaris 11 networking has "vanity naming" enabled by default (so things are named net0, net1, etc) . if you run 'dladm show-phys' you should be able to see the interface name you need to actually activate. instead of running 'ifconfig vmxnet3s0 plumb' you would instead run 'ifconfig net0 plumb' to activate the NIC.
To configure the network information on the virtual machine, refer to TCP/IP Administration section in the Oracle Solaris Administration: IP Services document.
Note: The above link was correct as of January 25, 2012. If you find a link is broken, provide feedback and a VMware employee will correct the link.
Example: A configuration might look like this:
To configure this information on the virtual machine:
/etc/nodename
file, by running this command:# echo "solaris15" > /etc/nodename
/etc/hostname.vmxnet3s0
, by running this command:# echo "solaris15" > /etc/hostname.vmxnet3s0
/etc/inet/ipnodes
file, by running this command:# echo "192.168.0.15 solaris15" >> /etc/inet/ipnodes
/etc/inet/hosts
file, by running this command:# echo "192.168.0.15 solaris15" >> /etc/inet/hosts
/etc/defaultrouter
file, by running this command:# echo "192.168.0.1" > /etc/defaultrouter
/etc/inet/netmasks
file, by running this command:# echo "192.168.0.0 255.255.255.0" >> /etc/inet/netmasks
# svcadm restart network/physical