Unable to Onboard LM Configuration into GM UI with Import Option Greyed Out
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Unable to Onboard LM Configuration into GM UI with Import Option Greyed Out

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Article ID: 303349

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Updated On:

Products

VMware NSX VMware NSX-T Data Center

Issue/Introduction

  • After the Local Manager appliance has been registered with the Global Manager and all unsupported configurations for features unsupported in Global Manager have been removed, you are unable to import the Local Manager configuration.
  • You login to the GM and navigate to System > Location Manager and select the Actions drop down for a LM site but the "Import to GM" button is disabled and non-selectable.

Environment

VMware NSX-T Data Center

Cause

This issue is caused by a race condition between API calls which check which Global Manager appliance is active and the import status of the Local Manager appliances.

Resolution

This issue is resolved in VMware NSX-T Data Center 3.2.0.

Run the following API call to import the LM configuration manually after confirming that a valid backup exists for the LM appliances.

GET https://<GMfqdn>/global-manager/api/v1/global-infra/federation-config

This API call will return the "site_id" UUID for each registered LM that needs to have its configuration imported.

POST https://<GMfqdn>/global-manager/api/v1/global-infra/sites/<LMfqdnSuffix>/onboarding?action=start_onboarding

Body:
{
"site_id":"<LMsiteUUID>",
"suffix":"<LMfqdnSuffix>",
"site_backup_reference":"2021-12-09-Site-0-backup"
}


GET https://<GMfqdn>/global-manager/api/v1/global-infra/sites/<LMfqdnSuffix>/onboarding/status

This API call validates the status of the configuration import for each LM targeted in the URI.

Workaround:
As this is a timing issue, refreshing the browser or navigating to different pages of the UI and back to Location Manager page may eventually allow for the UI to be used to import.  However, the functionality of this feature is intermittent with this method.