NSX Channel health status down on host
book
Article ID: 303274
calendar_today
Updated On:
Products
VMware NSX
Issue/Introduction
Symptoms:
- No connections on port 2134 or 5471.
- Running the two commands return nothing.
# esxcli network ip connection list | grep 5671
# esxcli network ip connection list | grep 1234
- vsfw and netcpa processes are in a wait state similar to:
# ps -s | grep vsfwd
37594 37594 vsfwd WAIT UFUTEX 0-127
37596 37594 vsfwd WAIT USLP 0-127
- In the NSX Manager logs, you see entries similar to:
(vim.fault.NoPermission) {
faultCause = null,
faultMessage = null,
object = ManagedObjectReference: type = OptionManager, value = EsxHostAdvSettings-27379, serverGuid = 9e1ac9d6-####-####-####-1f7b7e6e9682,
privilegeId = Host.Config.AdvancedConfig
}
Environment
NSX Data Center for vSphere
Cause
This issue occurs when the vCenter Server user that the NSX manager is using to log in to does not have the required permissions.
Resolution
To resolve the issue, add the user in the Administrator group or give the following privilege to the user: Host.Config.AdvancedConfig.
Feedback
thumb_up
Yes
thumb_down
No