Unable to Manage NSX through Web Client Plugin
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Unable to Manage NSX through Web Client Plugin

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Article ID: 303229

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptom:

Users are unable to manage NSX from the web client. When users click on Networking & Security > NSX Managers, no NSX Managers show up.

 

What to Look For:

NSX Managers in the top left corner shows "--" and not 0. If you see 0 instead of "--" look at permissions issues for the users.

 

Log Excerpts:

  • vCenter
    • Log Locations:
      • Appliance: /var/log/vmware/vsphere-client/logs
      • Windows: C:\ProgramData\Vmware\vCenterServer\logs\vsphere-client\logs
  • virgo.log

"The query execution timed out because of a back-end data adapter 'com.vmware.vshield.us.common.provider.VsmDataProviderAdapter' which took more than 120 seconds."

Cause

Corruption of the serenity database

Resolution

Important: Before attempting any of the steps below, make sure you have a recovery point prior to deleting or modifying any files. 

1. Stop the vSphere web client

# service-control --stop vsphere-client

2. Navigate to:

vCenter Server Appliance 5.x: /etc/vmware-vsphere-client/SerenityDB/

vCenter Server Appliance 6.x: /storage/vsphere-client/SerenityDB/

3. Make a directory to move the serenity files currently contained in the serenity folder

# mkdir serenity.old

4. Move all the files located within the serenity folder to the newly created serenity.old folder

# cd serenity
# mv . * ../serenity.old

5. Confirm the serenity folder is empty

6. Start the vSphere web-client again

# service-control --start vsphere-client

7. login to the vCenter web-client and navigate to Networking & Security > NSX Managers to confirm there are NSX Managers showing up in the top left corner.