"Exception: Failed to configure identity manager" error when upgrading to vCenter Server 6.5
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Article ID: 303145
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
Symptoms:
Upgrading to vCenter Server 6.5 fails with this error:
Encountered an internal error. Traceback (most recent call last): File "D:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.py", line 2018, in main vmidentityFB.boot() File "D:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.py", line 347, in boot self.configureIdentityManager(self.__idmRetryCount, self.__idmRetryInterval) File "D:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.p ", line 554, in configureIdentityManager raise Exception('Failed to configure identity manager') Exception: Failed to configure identity manager
In the vmware-sts-idmd.log file, there is an error similar to:
[ERROR] [IdmServer] IDM Server has failed to start java.lang.UnsatisfiedLinkError: Unable to load library'ssleay32.dll': The specified module could not be found.
Note: Thevmware-sts-idmd.log file is found in the VMware-VCS-logs-<year><month><day><hour><minute><second>.zip file which is created on on the vCenter Server after a failed upgrade.
In vmidentity-firstboot.py_PID_stdout.log you see the following error,
2016-11-30T14:53:56.901Z Exception: Traceback (most recent call last): File "C:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.py", line 2018, in main vmidentityFB.boot() File "C:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.py", line 346, in boot self.upgradeSystemDomainAdmins() File "C:\Program Files\VMware\vCenter Server\firstboot\vmidentity-firstboot.py", line 1968, in upgradeSystemDomainAdmins raise Exception('Failed to upgrade system domain admins.') Exception: Failed to upgrade system domain admins.
Cause
This issue occurs due to conflicting openssl libraries installed in the vCenter Server operating system.
Resolution
This is a known issue affecting vCenter Server 6.5.
Currently, there is no resolution.
Workaround: To workaround this issue uninstall, the application which published the conflicting Openssl libraries.
Additional Information
Environment variables listed under OPENSSL_CONF can also cause this issue.
For example:
If OPENSSL_CONF=C:\OpenSSL-Win32\bin\openssl.cfg, is listed instead of the default libraries included with vCenter Server, you can check the environmental variables by opening a command prompt and running the set command on the vCenter Server.