Symptoms: When attempting to register an AppDefense Appliance to the SSO Lookup Configuration upon initial configuration, the following error appears "AppD Server Internal Error occurred" when registering the configured lookup service.
See Photo Below:
Cause
The Fully Quantified Domain Name or IP address provided is an incorrect IP or does not resolve to the correct IP for the Platform Services Controller (or vCenter if the PSC is embedded).
Resolution
Ensure the DNS entry for PSC or vCenter with an embedded PSC is correct. Alternatively, test configuration to the PSC or vCenter with an embedded PSC by IP address. Please note, it is recommended to configure the Lookup service by FQDN