Installing or upgrading VMware Tools fails with the error: There is no disk in the drive
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Article ID: 302217
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
Symptoms:
Cannot install or upgrade VMware Tools
Installing or upgrading VMware Tools by navigating to Inventory > Virtual Machine > Guest > Install/Upgrade VMware Tools > Interactive Install in the vSphere Client fails
You see a Windows popup with this error before the system reboots:
Windows 2008 – There is no disk in the drive. Please insert a disk into the drive D:
Windows 2003 – Exception Processing Message c0000013 Parameters
Windows XP – There is no disk in the drive. Please insert a disk into drive D:
This issue does not occur if you:
Copy the VMware Tools Installation media to C:\ drive and then run it from the C:\ drive
Upgrade VMware Tools from the Windows Task Bar icon
Cause
This issue occurs because the VMware Tools installer unmounts the VMware Tools ISO while the installer is still reading from the ISO.
Resolution
This issue does not impact the installation of VMware Tools. You can safely click cancel and reboot the virtual machine to complete the VMware Tools installation.
This issue is resolved in ESXi 5.0 Update 2 released on December 20 2012. To download ESXi 5.0 Update 2, see the VMware Download Center.
To workaround this issue when you do not want to upgrade, use one of these methods when installing or upgrading VMware Tools:
Upgrade VMware Tools using the Windows Task Bar icon.
Copy the installation media to the local C:\ drive before running the installer.
Change the CD/DVD-ROM to a different drive letter other than D:\. For more information, see the Microsoft Knowledge Base article 307844.
Note: The preceding link was correct as of June 12, 2012. If you find the link is broken, provide feedback and a VMware employee will update the link.