Installing Single Sign-On fails with the error 20010: Failed to Configure LookupService
search cancel

Installing Single Sign-On fails with the error 20010: Failed to Configure LookupService

book

Article ID: 302165

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Cannot install Single Sign-On (SSO).
  • Installing SSO fails.
  • SSO Installer fails with the error:

    error: 20010: Failed to Configure LookupService

  • The imsTrace.log file (located in the C:\Program Files\VMware\Infrastructure\SSOServer\logs directory) shows the year 2555.
  • In the vminst.log file (located in the %temp% directory), you see entries similar to:

    VMware Single Sign On-build-797273: 10/16/12 16:30:50 Process returned 4294967295
    VMware Single Sign On-build-797273: 10/16/12 16:30:50 ERROR: Failed to run the command
    VMware Single Sign On-build-797273: 10/16/12 16:30:50 Posting error message 20010


  • In the discover-is.log file (located in the C:\Program Files\VMware\Infrastructure\SSOServer\utils\logs directory) you see entries similar to:

    2012-10-16 16:30:15,457 - center.vmware.local,,,,ERROR: Identity source discovery failed: Invalid input data. Validation failed
    Field: 'GssApiSupported', message: 'Test failed. Invalid user name or password specified'
    com.rsa.tools.common.action.exception.CLUExitException: Identity source discovery failed: Invalid input data. Validation failed
    Field: 'GssApiSupported', message: 'Test failed. Invalid user name or password specified'
    at com.rsa.riat.tools.is.DiscoverIdentitySources.execute(DiscoverIdentitySources.java:155)

  • In the vm_vim_ls.log file (located in the %temp% directory) you see entries similar to:

    [2012-10-16 16:30:50,035 main INFO com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl$RequestResponseProcessor] Request message has expired. Server message: ns0:MessageExpired: Request has expired
    [2012-10-16 16:30:50,037 main INFO com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl$RequestResponseProcessor] Server returned 'request expired' less than 0 seconds after request was issued, but it shouldn't have expired for at least 600 seconds.


  • The imsTrace.log file (located in the C:\Program Files\VMware\Infrastructure\SSOServer\logs directory) indicates that the STS request has expired:

    Note: In the log timestamp, the current year is set to 2555.

    2555-10-16 16:30:49,981, [castle-exec-2], (AuthnProcessorChain.java:77), trace.com.rsa.riat.ws.security.AuthnProcessorChain, DEBUG, center.vmware.local,,,,Invoking authentication handlers
    2555-10-16 16:30:49,983, [castle-exec-2], (ValidationHandler.java:66), trace.com.rsa.riat.ws.security.AuthnHandler, DEBUG, center.vmware.local,,,,Current time: Tue Oct 16 16:30:49 ICT 2012
    2555-10-16 16:30:49,985, [castle-exec-2], (ValidationHandler.java:83), trace.com.rsa.riat.ws.security.AuthnHandler, ERROR, center.vmware.local,,,,Request has expired
    2555-10-16 16:30:49,986, [castle-exec-2], (SecurityTokenServiceImpl.java:102), trace.com.rsa.riat.sts.impl.SecurityTokenServiceImpl, ERROR, center.vmware.local,,,,com.rsa.riat.core.WSSESecurityException: Request has expired


    Note: For more information, see Location of Single Sign On log files for vCenter Server 5.1 (2033430).


Cause

This issue occurs due to an incorrect system date and the local user's locale is set to Thailand time when executing the installer.

Resolution

This issue is resolved in VMware vCenter Server 5.1 Update 1, see the VMware vCenter Server 5.1 Update 1 Release Notes. You can download the latest release from the VMware Download Center.
To work around the issue if you are unable to upgrade, change the system local time to United States.

To change the system local time to United States:
  1. Navigate to Control Panel > Region & Language > Location.
  2. Change the system local time to United States.

    Note: This sets the system clock to the Gregorian calendar.
Note: The preceding link was correct as of September 13, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.


Additional Information


Location of vCenter Single Sign-On log files for vCenter Server 5.1 and 5.5
Single Sign-On のインストールがエラー 20010 [Failed to Configure LookupService] で失敗する