All ESX hosts simultaneously show a status of Not Responding in vCenter Server
search cancel

All ESX hosts simultaneously show a status of Not Responding in vCenter Server

book

Article ID: 301760

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • All ESX hosts simultaneously show a status of Not Responding in vCenter Server for approximately 30 seconds
  • This can occur approximately once per hour

Cause

This issue can occur if the time on the vCenter Server has changed.

To determine if the time has changed on the vCenter Server, check the vpxd.log file for entries similar to the following, around the time that the ESX hosts show a status of Not Responding:
[2009-06-11 11:44:19.023 'App' 2556 info] [VpxLRO] -- FINISH task-internal-1124329 -- -- vmodl.query.PropertyCollector.retrieveContents -- 46BDA3A0-####-####-####-########D3E
[2009-06-11 11:38:00.257 'App' 2552 info] [VpxLRO] -- BEGIN task-internal-1124330 -- -- vim.host.DiskManager.renewAllLeases -- 34CF8C47-####-####-####-########8FD
[2009-06-11 11:38:00.288 'App' 2552 info] [VpxLRO] -- FINISH task-internal-1124330 -- -- vim.host.DiskManager.renewAllLeases -- 34CF8C47-####-####-####-########8FD
[2009-06-11 11:38:06.257 'App' 2560 info] [VpxLRO] -- BEGIN task-internal-1124331 -- -- vim.host.DiskManager.renewAllLeases -- 34CF8C47-####-####-####-########8FD
[2009-06-11 11:38:06.289 'App' 2560 info] [VpxLRO] -- FINISH task-internal-1124331 -- -- vim.host.DiskManager.renewAllLeases -- 34CF8C47-####-####-####-########8FD
[2009-06-11 11:44:36.152 'App' 2528 info] [VpxLRO] -- BEGIN task-internal-1124332 -- -- vim.host.DiskManager.renewAllLeases -- 34CF8C47-####-####-####-########8FD
In this example, the time has changed from 11:44 to 11:38, then back to 11:44.
 
The time may change if:
  • The vCenter Server is running on a virtual machine whose VMware Tools are configured to synchronize time from the ESX host

    AND

  • The Windows operating system on the vCenter Server is configured to synchronize time from the time on the Domain Server

    AND

  • The time on the Domain Server is different to the time on the ESX host

    Note: If the time on the Domain Server is different to the time on the ESX host, the problem can occur when the system automatically attempts to synchronize the time, resulting in a time change in the vpxd.log file.
To display the Domain Server time:
  1. Open a Windows command prompt on the vCenter Server. For more information see, Opening a command or shell prompt (1003892).
  2. Run this command:

    net time /domain:domain_name

    where domain_name is the domain name associated with the Domain Server.

Resolution

This issue is resolved in vCenter Server 4.1 Update 2 and in vCenter Server 5.0 Update 1, available at VMware Downloads.
 
Alternatively, if you do not want to upgrade, ensure that the time on Domain Server and ESX hosts are the same.

Additional Information

  • For information about ESX time configuration, see Installing and Configuring NTP on VMware ESX Server (1339).
  • To display help information for the net time command, run the command net help time from a Windows command prompt.
  • In VirtualCenter 2.5, the vpxd.log files are by default stored in the C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs directory.