The SOAP Web Services interface might not be available after an upgrade to Service Desk Manager 12.9 Advanced Availability (AA) mode.
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The SOAP Web Services interface might not be available after an upgrade to Service Desk Manager 12.9 Advanced Availability (AA) mode.

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Article ID: 30172

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

In the previous version, it was common for the SOAP Web Service interface to be configured on the primary server. However, after migration to Service Desk Manager 12.9 (or above) Advanced Availability (AA) mode, the web service will be disabled on the background server. This is because the web service interface is supposed to be run on an application server only. Any products or interfaces integrated with SDM via axis Web Service maybe still trying to access web services on the background server (previously the primary server), so that all those would fail.

Environment

CA Service Desk 17.1 and higher.

Cause

All products, such as Process Automation Manager (PAM) or ITCM, that use the axis Web Services interface, fail after migration to Service Desk Manager 12.9 Advanced Availability (AA) mode.

e.g. For PAM, the following error may be written to the c2o.log

ERROR [com.optinuity.c2o.service.serviceoperation.casdserviceoperation.CASDWrapper] [41-9d48ec8e4aa1] Fault returned by the WebService:
   ns1:Server.NoService
   The AXIS engine could not find a target service to invoke!  targetService is USD_R11_WebService

When you access the URL http://<SDM host>:<port>/axis/services, you may see an error saying:  cannot find USD_R11_WebService(wsdl) 

Resolution

Redeploy the web services on the background server as described in the Service Desk Implementation Guide. ( Page 532, 'Redeploy the Web Services' section)

OR

As per the best practice, deploy Web Services on an application server, and configure the integrated product(s) to access the application server.