スナップショット作成操作が、停止した仮想マシンでの I/O 保留時間制限を超えたため静止スナップショットを作成できない
search cancel

スナップショット作成操作が、停止した仮想マシンでの I/O 保留時間制限を超えたため静止スナップショットを作成できない

book

Article ID: 301541

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

免責事項: これは英文の記事「Cannot create a quiesced snapshot because the snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine (1018194)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


 

  • 静止スナップショットの作成に失敗します。
  • スナップショットの作成時に次のエラーが表示されます:

    Cannot create a quiesced snapshot because the snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine
     
  • この問題は、仮想マシンのホット クローンを作成するときにも発生する場合があります。次のエラーが表示されます:

    An error occurred while quiescing the virtual machine.See the virtual machine's event log for details 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)
     
  • vpxa.log ファイルに次のようなエントリが含まれます:

    : VMware Infrastructure 3.x および vSphere 4.x では、ログは /var/log/vmware/vpx/vpxa にあります。vSphere 5.0 では、ログは /var/log にあります。

    2010-10-10T22:53:31.077Z [45EEEB90 info 'Default' opID=D1D8F924-00002337-83] [VpxLRO] -- ERROR task-768 -- -- vpxapi.VpxaService.createSnapshot: vim.fault.ApplicationQuiesceFault:
    --> Result:
    (vim.fault.ApplicationQuiesceFault) {
    dynamicType = <unset>,
    faultCause = (vmodl.MethodFault) null,
    faultMessage = (vmodl.LocalizableMessage) [
    (vmodl.LocalizableMessage) {
    dynamicType = <unset>,
    key = "msg.snapshot.quiesce.vmerr",
    arg = (vmodl.KeyAnyValue) [
    (vmodl.KeyAnyValue) {
    dynamicType = <unset>,
    key = "1",
    value = "5",
    },
    (vmodl.KeyAnyValue) {
    dynamicType = <unset>,
    key = "2",
    value = "'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)",
    }
    ],
    message = "The Guest OS has reported an error during quiescing.
    --> The error code was: 5
    --> The error message was: 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)
    --> ",
    }
    ],
    msg = "An error occurred while quiescing the virtual machine.See the virtual machine's event log for details."
    }
    --> Args:
    --> Arg vmid:6
    --> Arg name:"clone-temp-1286776661914351"
    --> Arg description:
    "This temporary snapshot is taken as part of the clone operation.The temporary snapshot will be deleted once the clone operation is complete."
    --> Arg memory:false
    --> Arg quiesce:true
     
  • 仮想マシンの vmware.log には、次のようなエントリが含まれます:

    2010-10-10T23:02:12.050Z| vcpu-3| [msg.snapshot.quiesce.vmerr] The Guest OS has reported an error during quiescing.
    2010-10-10T23:02:12.050Z| vcpu-3| --> The error code was: 5
    2010-10-10T23:02:12.050Z| vcpu-3| --> The error message was: 'VssSyncStart' operation failed: IDispatch error #8449 (0x80042301)

:前述のログの引用は単なる例です。 日付、時間、および環境変数は、環境によって異なる場合があります。


Cause

この問題は、仮想マシン内の I/O が高く、静止操作ですべてのデータをディスクにフラッシュできないとき、さらに I/O が作成されると発生します。

この問題は、空き領域がない仮想マシン上で静止スナップショットを作成しようとする場合にも発生する可能性があります。これは、仮想マシン上の空き領域が 0 バイトであるということです。

Resolution

注: この問題は、仮想マシン内にサードパーティのバックアップ エージェントをインストールし、再起動をしていない場合に発生する場合があると報告されています。これに該当する場合は、仮想マシンを再起動して問題が解決されるかどうかを確かめてから、この先のトラブルシューティングに進んでください。

この問題を解決するには、次のいずれかのオプションを実行します。

  • VSS、ゲスト、およびバックアップ製品の構成を確認します。VSS に関する追加のトラブルシューティング手順については、Troubleshooting Volume Shadow Copy (VSS) quiesce related issues (1007696) を参照してください。
     
  • 仮想マシンに対する実行中の I/O の量を減らします。これは、プレフリーズまたはポストフリーズのスクリプトを使用してアプリケーション I/O を静止することで実行できます。詳細については、次を参照してください。
     
  • ファイル システムの静止を回避することで仮想マシンの(アプリケーションの整合性を保つのではなく)クラッシュ時の整合性を保つスナップショットを選択します。


スナップショット作成中に仮想マシンを静止したくない場合は、いくつかのオプションがあります。環境に基づいて、次のいずれかのオプションを選択してください。

  • VMware Consolidated Backup(VCB)をまたは VCB フレームワークに依存するバックアップ製品を使用している場合は、『仮想マシン バックアップ ガイド』 の 「静止メカニズム」 を参照してください。

    : vSphere 5.0 は VCB をサポートしていません。
     
  • ESXi 5.x または ESXi/ESX 4.x で手動でスナップショットを作成する場合は、スナップショットの作成時に vSphere Client の 静止ゲスト ファイル システム オプションを選択解除します。ESXi/ESX 3.5 では、VMware Infrastructure Client から静止スナップショットを作成することができません。
     
  • VMware Tools の機能である pre-freeze および post-thaw スクリプトを使用してバックアップを取る前にアプリケーションを停止し、あとで再起動することもできます。詳細および関連情報については、『仮想マシン バックアップ ガイド』 の 「カスタム静止スクリプトの実行」 のセクションを参照してください。
     
  • vim-cmd コマンドを使用して ESXi ホスト経由でスナップショットを作成する場合は、静止オプションを 0 に設定します。

    仮想マシンとその VMID のリストを取得するには、次のコマンドを実行します:

    # vim-cmd vmsvc/getallvms

    静止を 0 に設定するには、次のコマンドを実行します:

    # vim-cmd vmsvc/snapshot.create vmid [snapshotName] [snapshotDescription] [includeMemory] [quiesced]

    たとえば、仮想マシンの名前が testVM で、VMID 23 の場合、コマンドは次のようになります:

    # vim-cmd vmsvc/snapshot.create 23 "SnapName" "Snap Description" 0 0
     
  • vmware-cmd コマンドを使用して ESX ホスト端末経由でスナップショットを作成する場合は、静止オプションを 0 に設定します。

    静止を 0 に設定するには、次のコマンドを実行します:

    # vmware-cmd cfg createsnapshot name description quiesce memory

    例:

    # vmware-cmd /vmfs/volumes/4adecc3a-62b367e8-5b15-001a4be960e0/VMname/VMname.vmx createsnapshot "Snap Name" "Snap Description" 0 0
     
  • 非静止スナップショットを構成できないサードパーティのバックアップ製品を使用している場合は、VMware Tools の一部として提供されている Windows ゲスト OS から VSS を削除します。こうすると、VMware Tools は古い Sync ドライバを使用しようとします。静止スナップショットの要求時に、VMware Tools は VSS ドライバを見つけて利用することができないため、Sync ドライバを使用して静止を試みます。VSS オプションなしで VMware Tools を再インストールするには:
     
    1. VMware Tools をアンインストールします。
    2. システムを再起動します。
    3. VMware Tools を再インストールします。必ず カスタム インストール をクリックしてください。
    4. VSS を選択解除します。

    • これには、仮想マシンの再起動が必要です。VMware は、この操作を実行する前にダウンタイムのスケジュール設定をしておくことをお勧めします。
    • ESXi/ESX 4.1 以降では、Windows Server 2003 および以降のバージョンの Windows で VSS を選択解除し、Sync ドライバを使用するオプションは利用できなくなっています。静止オプションで作成したスナップショットでは、ゲスト OS 内で Volume Shadow Copy サービスが無効化されている場合を除き、デフォルトで VSS を使用してゲスト OS ファイル システムを静止するようになります。
    • インストール後は、たとえ明確に要求された場合でも、静止操作を実行することなく、スナップショットを取ることができるようになります。

  • Windows の古いバージョンと VMware ESX 3.5 Update 2 より前にデプロイされたゲストは、静止スナップショットの要求に VSS ではなく Sync ドライバを使用します。
     
  • Microsoft は、Exchange サーバのスナップショットをサポートしていません。スナップショットのサポートの詳細については、次の Microsoft TechNet のドキュメントを参照してください:
:このリンクは 2015 年 10 月 1 日時点のものです。リンクが切れている場合はフィードバックをお寄せください。VMware の担当者がリンクを更新します。
 
  • Microsoft Exchange を実行する仮想マシンと Symantec NetBackup ツールを併用する場合は、Symantec VSS プロバイダの使用を検討してください。詳細は、『NetBackup for VMware 7.1 管理者ガイド』 の 「VMware 用の Symantec VSS プロバイダ」 のセクションを参照してください。VMware Tools が、Symantec VSS の前にインストールされている場合は、NetBackup 管理者ガイドを参照し、VMware Tools をアンインストールして VMWare VSS なしで再インストールしてください。Symantec VSS の削除が必要な場合は、Symantec VSS サービスのアンインストール/再インストール について Symantec にお問い合わせください。
     

    :このリンクは 2015 年 10 月 1 日時点のものです。リンクが切れている場合はフィードバックをお寄せください。VMware の担当者がリンクを更新します。
     

  • この問題は、いずれかの VSS ライタに不具合がある場合にも発生する可能性があります。バックアップ ジョブの実行前およびジョブの終了後にライタのリストを確認します。これにより、いずれかの VSS ライタに不具合があるかどうかを確認できます。VSS ライタはサードパーティ ベンダーによって提供されているため、それらのライタの問題や不具合のトラブルシューティングについては、当該のベンダーにお問い合わせください。


Additional Information