After upgrading vCenter, vLCM updates tab is missing Baselines, Image and Hardware compatibility
search cancel

After upgrading vCenter, vLCM updates tab is missing Baselines, Image and Hardware compatibility

book

Article ID: 301486

calendar_today

Updated On:

Products

VMware vCenter Server VMware vCenter Server 8.0

Issue/Introduction

  • After the upgrade of vCenter to version 8.x, when selecting a cluster and clicking on the updates tab, the menu option for "Baseline," "Image," and/or "Hardware Compatibility" is lost
  • Users within the SystemConfiguration.Administrators group are still unable to view the rest of the objects under the Updates tab.
  • vCenter - /var/log/vmware/vsphere-ui/logs/apigw.log displays the following:

    Caused by: com.vmware.vcenter.apigw.lookup.ServiceLocatorException: Found multiple endpoints node='Node_ID' product='com.vmware.applmgmt' serviceType='applmgmt' protocol='vapi.json.https.public' endpointType='com.vmware.applmgmt'

Environment

VMware vCenter Server 8.0

Cause

Duplicate endpoints within the lookup service registration are known to cause issues within vCenter that prevent normal workflows from executing. 

Resolution

Before proceeding, ensure to have a valid snapshot or a backup before proceeding. For further information on taking snapshots of the vCenter when in ELM, refer to KB VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice.

  1. SSH to the affected vCenter via root

  2. Identify the corresponding duplicate service by referring to KB "VMware vAPI Endpoint Service Health Alarm" due to the duplicate service registrations after upgrading vCenter to 7.0. Alternatively, utilize the lsdoctor tool from KB Using the 'lsdoctor' Tool using option -l (--lscheck) to print a report.

  3. Remove the duplicate service with lstool.py and the corresponding Service-ID:

    /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url https://localhost/lookupservice/sdk --id <Service-ID> --user '[email protected]' --password '<password>' --no-check-cert

  4. Restart all services or reboot the VCSA

    service-control --stop --all;service-control --start --all

  5. After all services have started, log into the vCenter UI and review the cluster Updates' tab.