Issue:
The customer had upgraded all PIM servers from Jdk 7u21 to 7u75 and altered the registry keys to point to the new java version. In the distribution server, java would install, but in the task manager the process would be calling on the 7u21 directory (although specifying a new installation directory). For their company’s security requirements the same directories would have to be used for all servers.
Environment:
PIM 12.8 - 12.9
Windows 2008 +
Cause:
The cause for this stems from the incorrect JAVA directory being located and pointed to for the service associated
Resolution:
To support JDK 1.7 U17on the Enterprise Management Server you must modify the Java Connector Server (JCS). Do the following:
Windows 2008 Server 32 bit operating system
The Registry Editor opens.
Windows 2008 Server R2 64 bit operating system
The Registry Editor opens.
C:\Program Files (x86)\Java\jdk1.7.0_17\jre\bin\client\jvm.dll
**Above is the required steps for java installation-- if it still utilizes the older version follow below steps**
Further Solution:
1. 1. Ensure the java process in task manager isn’t in the correct directory
2. 2. Stop the java connector server service
3. 3. Navigate to C:\Program Files\CA\AccessControlDistServer\JCS\bin
4. 4. Create a backup of acjcswrap configuration settings
5. 5. Edit the new acjcswrap command line to the correct location of the java.exe
6. 6. Save the file after making the directory change and start the service. Check the properties of the process in task manager for the correct location to be called.