Anti-Virus for VMware Tanzu is restarting every day
search cancel

Anti-Virus for VMware Tanzu is restarting every day

book

Article ID: 298405

calendar_today

Updated On:

Products

VMware Tanzu Application Service for VMs

Issue/Introduction

Anti-Virus for VMware Tanzu is restarting every day

ClamAV process is restarting every day when new virus definitions are downloaded.

Symptoms:
You may observe the following warning in the logs:
warning message
2023-07-22T10:04:59.955801Z 2184d5bb-528d-4b99-8c95-dd21f4dbaf60.diego_cell.services.cf-6fbad9827f2d.bosh antivirus[rs2] 2023/08/22 08:04:59 Warning: Couldn't talk to clamd: dial unix /var/vcap/sys/run/antivirus/clamd.socket: connect: connection refused

Environment

Product Version: 2.13

Cause

Anti-Virus for VMware Tanzu updates its virus database twice a day. To ensure no downtime, there needs to be enough memory allocated to hold the old and new databases in memory for a short period. If there is insufficient memory, a restart is needed.

Resolution

The minimum recommended memory required by Anti-Virus may have changed since the product was installed.
Ensure that the tile config reserves a minimum of 3Gb of memory for AV (4GB preferred).
Set the Memory limit (in bytes) to a minimum value of 3221225472 in the Anti-Virus tile.
https://docs.vmware.com/en/Anti-Virus-for-VMware-Tanzu/2.3/anti-virus/GUID-install.html#configure-antivirus-2