Upgrading Pivotal Cloud Foundry to Version 1.4 with the Pivotal HD Tile Deployed Results in an Error
search cancel

Upgrading Pivotal Cloud Foundry to Version 1.4 with the Pivotal HD Tile Deployed Results in an Error

book

Article ID: 297796

calendar_today

Updated On:

Products

VMware Tanzu Application Service for VMs

Issue/Introduction

Symptoms:

This issue occurs when Pivotal Cloud Foundry (PCF) Version 1.3.x with the Pivotal Hadoop Distribution (HAWQ) Version 1.3.x Tile installed.

When trying to upgrade Pivotal Cloud Foundry version 1.3.x to Pivotal Cloud Foundry version 1.4.x, you get an error message"Stemcell version must be 2690.3 or greater". You have the Pivotal Hadoop Distribution (HD) Tile installed.

 

Environment


Cause

The root cause is that the current version of the Pivotal HD tile uses an older Stemcell which is not compatible with PCF version 1.4 and above.

Resolution

Pivotal HD tile needs to be removed from the Operations Manager prior to exporting your configuration. The following steps can walk you through this process:

  1. In Operations Manager 1.3.x, uninstall the Pivotal HD tile. Prior to doing this, we recommend deleting any services used by your applications that are using the Pivotal HD tile. If you do not, there will be orphaned service instances and bindings which will need to be cleaned up with the "cf purge-service-offering" command. Please see the "Impact" section below for how this will affect the data stored in the service.
  2. Export the installation, just like you would normally do.
  3. Import the installation, again just like you would normally do.

When the installation imports, it should no longer have the Pivotal HD tile and you should be able to apply changes without any errors. If you have applications that require Pivotal HD, the current recommendation is to run an externally managed Pivotal HD installation. You can then set up a user provided service with the "cf cups" command and bind that to your applications.


Impact

Important: Please be aware that deleting the Pivotal HD tile from Operations Manager will result in the deletion of all services provisioned by that tile and any data associated with those services. Before you delete, make sure that you have backed up or migrated any data that you need to retain.