TAS Manage Notifications Page has missing e-mail options
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TAS Manage Notifications Page has missing e-mail options

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Article ID: 297794

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Updated On:

Products

VMware Tanzu Application Service for VMs

Issue/Introduction

Symptoms:
The TAS Manage Notifications page is missing e-mail options for a user after successfully configuring Simple Mail Transfer Protocol (SMTP) within TAS and successfully running the TAS errands Notifications and Notifications UI.

Furthermore, the Manage Notifications page looks like this:


However, the Manage Notifications page should look like this as per the document, https://techdocs.broadcom.com/us/en/vmware-tanzu/platform/tanzu-platform-for-cloud-foundry/6-0/tas-for-vms/autoscaler-using-autoscaler.html

Environment

 

Cause

This issue occurs when a user is new and has not been notified yet.

Resolution

There are two things that must happen before a user will see the Manage Notifications options.

1. The user needs to have the Space Developer role assigned to the space where a notifying application is running.

2. The application must have sent at least one notification to the notifications application for a user.

One way to test this is working is by creating an autoscaler service and bind it to an application in a space where a user has the Space Developer role.

 
a. Drill into the application and set the autoscaler instance limits to min 1 and max 5.

b. Then create an autoscaler rule for Container Memory low 1% and high 2%. This will cause the application to breach the threshold, scale, and trigger a notification with autoscaler, which will get sent to the notification app.

c. Once this happens, you will notice that the e-mail options for the user will appear on the preferences page.


Note: When using autoscaler to test this, setting min and max to scale the app is not enough. You must set up a rule.