Diego Rep Process Fails to Start when Updating the Cell After Upgrade from Pivotal Cloud Foundry 1.7 to 1.8
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Diego Rep Process Fails to Start when Updating the Cell After Upgrade from Pivotal Cloud Foundry 1.7 to 1.8

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Article ID: 297646

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Updated On:

Products

VMware Tanzu Application Service for VMs

Issue/Introduction

Symptoms:

After upgrading from PCF 1.7 to PCF 1.8, Diego Cell rep process fails to start and reports the following in rep.stdout.log

{"timestamp":"1477582441.841048717","source":"rep","message":"rep.max-cpu-shares-invalid","log_level":2,"data":{}}
{"timestamp":"1477582441.841185570","source":"rep","message":"rep.garden-healthcheck-process-user-invalid","log_level":2,"data":{}}
{"timestamp":"1477582441.841197968","source":"rep","message":"rep.garden-healthcheck-process-path-invalid","log_level":2,"data":{}}
{"timestamp":"1477582441.841247559","source":"rep","message":"rep.","log_level":3,"data":{"error":"failed-to-configure-executor","trace":"goroutine 1 [running]:\ncode.cloudfoundry.org/lager.(*logger).Fatal(0xc42015e0c0, 0x0, 0x0, 0xd0bc40, 0xc4200148d0, 0x0, 0x0, 0x0)\n\t/var/vcap/packages/rep/src/code.cloudfoundry.org/lager/logger.go:131 +0xc7\nmain.main()\n\t/var/vcap/packages/rep/src/code.cloudfoundry.org/rep/cmd/rep/main.go:106 +0x29ed\n"}}

 

 

Environment


Cause

If the availability zone name defined in the BOSH Director tile has spaces in it, the rep process may fail to start. This is a bug in Diego cell and is expected to be fixed in an upcoming release. The fix for this issue is in Diego Release v0.14880 and the current Pivotal Application Service Version is 1.8.12 which uses Diego Release v0.14850.

 

Resolution

Upgrading to the new Diego Patch once it becomes available will help resolve this problem. If you have encountered this problem and the ERT fix is not yet available, then we advise contacting pivotal support for help.