Unable to push Windows apps and Windows cells are reporting Unresponsive
search cancel

Unable to push Windows apps and Windows cells are reporting Unresponsive

book

Article ID: 297636

calendar_today

Updated On:

Products

VMware Tanzu Application Service for VMs

Issue/Introduction

Symptoms:
Application pushes that require Windows Deigo cells fail. 

BOSH VM's output shows failing or unresponsive windows cells:  



Logging into the Windows Diego Cells shows may connections in time_wait using netstat -an



Finally reviewing % Privileged Time in Performance Monitor shows a sizable amount of CPU (20% or higher) is being spent within the Window Kernel.

Environment


Cause

Windows Monthly Rollup July 10, 2018 (​https://support.microsoft.com/en-us/help/4338818/windows-7-update-kb4338818) contains an issue that effects TCP port usage.

Resolution

Patching the Windows Stemcells to 1200.23 or higher is the recommended course of action.

Windows Monthly Rollup August 14, 2018 (https://support.microsoft.com/en-us/help/4343900) addresses the TCP port issue.

Github link for customers who have to build their own stemcells:
https://github.com/cloudfoundry-incubator/bosh-windows-stemcell-builder/tree/1200.23