PXF JIRA CheckList
search cancel

PXF JIRA CheckList

book

Article ID: 296920

calendar_today

Updated On:

Products

VMware Tanzu Greenplum VMware Tanzu Data Suite VMware Tanzu Greenplum / Gemfire

Issue/Introduction

This is a list of artifacts that R&D need for investigation of PXF issues.

Environment

Greenplum with PXF (Platform eXtension Framework)

Resolution

A: Greenplum, OS and Java information:

  • What is the Greenplum Database version?
psql template1 -c "select version();"
  • What is operating system the product is running on?
    • If Linux, which distribution and specific version (e.g. RHEL 7.8 vs RHEL 7.9)
cat /etc/redhat-release
  • What is the version of the Java Virtual Machine?
java -version
  • What are the memory(JVM) settings?
${JAVA_HOME}/bin/java -XX:+PrintFlagsFinal -version | grep HeapSize
  • What is the value of PXF_JVM_OPTS present in $PXF_BASE/conf/pxf-env.sh?


B: PXF information:

  • What is the PXF product version?
pxf version
  • What is the external table definition? If an external table definition is not provided, then:
    • What PXF profile is being used (e.g. hdfs:parquet, s3:json, jdbc)?
    • How many columns and what column types
    • What is the name of the PXF server (i.e., SERVER=...)
    • Are there any additional query parameters in the location URL (e.g., VECTORIZE=[true|false], PPD=[true|fase], IGNORE_MISSING_PATH=[true|false])
  • Full query syntax for the query that is being run.
  • Does the error always happen, or is it intermittent?
    • Does it only occur when there is a large number of concurrent queries using PXF?
    • How much (approximately) data is being read by the PXF service (e.g., number of files, size of files, etc)
  • What is the psql error that is displayed?
    • Does the error indicate which segment host the error occurred on?
    • If yes, we need segment logs for the segment that reported the error.
  •  Are there PXF service logs? At a minimum, there should be a log file from the segment host where the error occurred but it would be better if we had logs from all segment hosts.
  • Do we have the PXF server configuration directory for the server set in the external table definition?
    • Depending on the PXF profile that is utilised, the following config files will be needed:
HDFS
hdfs-site.xml
core-site.xml

JDBC
jdbc-site.xml

Amazon S3
s3-site.xml

Google Cloud Storage
gs-site.xml

Azure
adl-site.xml

Hive
hive-site.xml
hdfs-site.xml
core-site.xml

In addition to all to these profile-specific files, there should also be a pxf-site.xml in the specific directory.
  • Contents of the PXF service configuration directory? Relevant files are:
$PXF_BASE/conf/pxf-env.sh
pxf-application.properties
  • For Kerberos issues: is the PXF server configured to use Kerberos authentication?
    • Does pxf-site.xml have valid looking Kerberos properties?
    • Is there any confirmation that the Kerberos principal and keytab are valid and work? 
    • Verify the keytab by running this command on the PXF segment hosts
    • Output from the command below should include the principal name that is listed in pxf-site.xml
klist -etK -k $PXF_BASE/keytabs/pxf.service.keytab