gprestore fails with "Pipes can no longer be created. Exiting with error"
search cancel

gprestore fails with "Pipes can no longer be created. Exiting with error"

book

Article ID: 296895

calendar_today

Updated On:

Products

VMware Tanzu Greenplum VMware Tanzu Greenplum / Gemfire

Issue/Introduction

  • Error message: gpbackup_helper: [ERROR]: -Segment X: Oid Y: Pipes can no longer be created.

  • Related error: Exiting with error: open /path/to/pipe: no such device or address

  • Context: Occurs during gprestore operations on versions 1.25.1 through 1.29.1.

gprestore may report the following error:

20230720:09:00:21 gpbackup_helper:gpadmin:sdw01:2478848-[ERROR]:-Segment 3: Oid 1387270: Pipes can no longer be created. Exiting with error: open /data/primary/gpseg3/gpbackup_3_20230707230436_pipe_1566204_1387270: no such device or address
20230720:09:00:21 gpbackup_helper:gpadmin:adw01:2478848-[DEBUG]:-Segment 3: Removing pipe /data/primary/gpseg3/gpbackup_3_20230707230436_pipe_1566204_1387270
 

Environment

gprestore 1.25.0 - 1.29.1

Resolution

Fix

gprestore 1.29.2 and above.