Query Monitor is not reflecting running queries in GPCC Tool
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Query Monitor is not reflecting running queries in GPCC Tool

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Article ID: 296468

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Updated On:

Products

VMware Tanzu Greenplum

Issue/Introduction

Greenplum Command Center (GPCC) is not displaying the list of queries running in Greeplum Database (GPDB) cluster. The following error message is displayed:
Error: GPCC is no longer receiving updates. Check your network status or gpcc status and refresh this page.

This is a generic error message and may have a number of causes. One possible cause is given below for AWS environments.


Cause

The GPDB cluster and GPCC are running in AWS environment. The load balancer used to access the DBs and GPCC is Elastic Load Balancer (ELB). ELB does not support WebSockets, which are used by GPCC WebUI to retrieve updates for the GPCC server.

See:

https://aws.amazon.com/blogs/aws/new-aws-application-load-balancer/ for information on WebSockets support in AWS.

Environment

Product Version: 5.21

Resolution

Fix

If the GPDB cluster is running on AWS then use Application Load Balancer (ALB) instead of ELB.


Workaround

Configure ELB to use TCP protocol instead of HTTP protocol when accessing the GPCC service port.