Greenplum External Queries fail with "javax.security.auth.login.LoginException: connect timed out"
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Article ID: 295929
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Updated On:
Products
VMware Tanzu Greenplum
Issue/Introduction
Symptoms: Greenplum External queries are failing.
The Greenplum Master log or Segment logs show the following during failed external queries to a Hadoop platform:
Exception in thread ""main"" java.io.IOException: Login failure for gpadmin/[email protected] from keytab /home/gpadmin/gpadmin.hadoop.keytab: javax.security.auth.login.LoginException: connect timed out
at org.apache.hadoop.security.UserGroupInformation.loginUserFromKeytab(UserGroupInformation.java:987)
Environment
Cause
When Kerberos security is enabled, this can occur when there are issues communicating with the Kerberos KDC host(s) configured in the /etc/krb5.conf on the segment hosts. The issues can be network related or related to resource issues on the remote Kerberos KDC host itself.
Resolution
This can happen if the /var/log file system on the Kerberos KDC host fills up. Amongst other things, you should also look for issues on the remote Kerberos KDC server host, such as:
- Issues with KDC file systems, logging, etc - Available memory - Available CPU - Load - Socket connections - Kerberos settings