Timezone setting shows no data on charts
search cancel

Timezone setting shows no data on charts

book

Article ID: 295729

calendar_today

Updated On:

Products

VMware Tanzu Greenplum

Issue/Introduction

Dashboard and Cluster Metrics views show no data in the histogram charts.

Cause

This issue is caused when the default timezone has changed for the gpmon user and the gpperfmon database. Pivotal Greenplum Command Center (GPCC) requires that the gpmon user and the gpperfmon database use the same default timezone as that of the system they are operating on. 

Resolution

Run the following query to fix this issue:

psql gpperfmon
alter user gpmon reset timezone;
alter database gpperfmon reset timezone;
restart gpcc