Greenplum Command Center time "Last Sync" is not synced with the server time
search cancel

Greenplum Command Center time "Last Sync" is not synced with the server time

book

Article ID: 295600

calendar_today

Updated On:

Products

VMware Tanzu Greenplum

Issue/Introduction

Symptoms:
When checking the "Last Sync" time from the top right of the GPCC dashboard, the time displayed is not the same as the Database Server time.

Environment


Cause

"Last Sync" is an operation performed by the Gpperfmon Database.

Resolution

Follow the steps below to set the timezone for the Gpperfmon Database to the same the same timezone as the server.

1. Check server timezone using the following comnmand:

date +"%Z %z"

2. Run the following query to find the timezone used in the Gpperfmon Database.

psql gpperfmon -c 'select * from pg_timezone_names where abbrev='UTC' 

Note: UTC is the value found in step 1. 

3. Set the Gpperfmon Database timezone to the same the timezone of the server.

psql gpperfmon -c "alter database gpperfmon set timezone to 'Universal'" 

4. Reopen the GPCC dashboard and confirm the timezone is correct.