Unable to Log On to GPCC, Error "Incorrect username/password"
search cancel

Unable to Log On to GPCC, Error "Incorrect username/password"

book

Article ID: 295403

calendar_today

Updated On:

Products

VMware Tanzu Greenplum

Issue/Introduction

Symptoms:
  • After verifying that the username and password are correct when trying to log on to GPCC, the error message "Incorrect username/password" is seen.
  • The following errors are seen in the Master logs:

Error Message:

2016-06-27 14:27:41,741 - Checking trust login for gpmon on db gpperfmon, host localhost, port :5432
2016-06-27 14:27:41,750 - Trust login not allowed.  User gpmon has trust login enabled
2016-06-27 14:27:41,751 - Authentication failed user(gpmon) allow_trust_logon(False): Incorrect username/password

Environment


Cause

The gpperfmonui.conf parameter allow_trust_logon is set to "no" and the user (or all users) is a trusted user. This means that it refuses to let you log on as you are trying as a trusted user. 

On checking the pg_hba.conf file, you should see that you as a user or all users are trusted:

host     all         all             127.0.0.1/28    trust
<user>   all         all             127.0.0.1/28    trust

 

Resolution

Follow the steps to resolve this issue:

  1. Remove the trusted user line from the pg_hba.conf and replace it with md5
    Or
  2. Turn the "allow_trust_logon = yes" in the gpperfmonui.conf for the instance you are logging on to.