Zeppelin Web UI Showing "Disconnected" State in Pivotal HD
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Zeppelin Web UI Showing "Disconnected" State in Pivotal HD

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Article ID: 294741

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Updated On:

Products

Services Suite

Issue/Introduction

Symptoms:
After deploying the HDP 2.4 cluster, Zeppelin web UI is shows a "Disconnected" state.

Environment


Cause

The Chrome browser failed to authenticate with the proxy server when it tried connecting to the Zeppelin server via a web socket.

When you open the "Developer Tools" window in a Chrome browser, Chrome browser tries to establish a web socket to the Zeppelin server with an anonymous login and the command is refused.

Successful connection to the same URL from a desktop with no proxy server configuration was required.

Resolution

Refer to the following options to resolve this issue:

  1. Access Zeppelin web service from an environment where no proxy server is needed.
  2. Add some extensions like "Proxy Helper", which allows only specific authentication information to Chrome browser.
  3. Try running it with the Firefox browser which will ask you to input username/password when required.