"/home/tempest-web/tempest/web/vendor/uaac/Gemfile not found" message after UAAC command fails on Ops Manager v2.10.9 with Ubuntu user
search cancel

"/home/tempest-web/tempest/web/vendor/uaac/Gemfile not found" message after UAAC command fails on Ops Manager v2.10.9 with Ubuntu user

book

Article ID: 293801

calendar_today

Updated On:

Products

Operations Manager

Issue/Introduction

As of Ops Manager v2.10.9 (both vSphere and AWS versions), any use of the `uaac` command fails on the Ops Manager VM with the message:
/instance with "/home/tempest-web/tempest/web/vendor/uaac/Gemfile not found"


Cause

"[Bug Fix] Restrict permissions on the /home/tempest-web and /home/ubuntu directories to 750", where permissions of the directories, /home/tempest-web and /home/ubuntu, on the Ops Manager VM are considered as a possible avenues for privilege escalation. These permissions are 750 on the latest release of Ops Manager.

This issues arises when the permissions are currently 755, which allows other users to write content to these directories.

Environment

Product Version: 2.10

Resolution

Workaround

To bypass this problem, follow one of the following workarounds below:

Workaround 1 

Run uaac with sudo:
sudo uaac

Workaround 2

Comment the .profile for the Ubuntu user. 

a. To edit the file, run the command, sudo vim .profile.
cat .profile
export RAILS_ENV=production

alias uaac='BUNDLE_GEMFILE=/home/tempest-web/tempest/web/vendor/uaac/Gemfile bundle exec uaac'

ubuntu@opsmgr-06-slot-50-pez-vmware-com:~$ sudo vim .profile
 
b. Update the file and comment the alias:
cat .profile
export RAILS_ENV=production

#alias uaac='BUNDLE_GEMFILE=/home/tempest-web/tempest/web/vendor/uaac/Gemfile bundle exec uaac'
 
c. Logout from the system and log back in.

Note: Logging out and logging back in with the same command will work without issue.