Importing Operations Manager configuration fails with OpenSSL Cipher error
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Importing Operations Manager configuration fails with OpenSSL Cipher error

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Article ID: 293583

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Updated On:

Products

Operations Manager

Issue/Introduction

Symptoms:

Error Message:

500 An error occurred.
Contact Pivotal Technical Support to report the problem.

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OpenSSL::Cipher::CipherError

/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:98:in `final'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:98:in `crypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:49:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:233:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:317:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:155:in `block (2 levels) in attr_encrypted'
/home/tempest-web/tempest/web/app/models/uaa/uaa_config_writer.rb:82:in `generate_uaa_yml'

Environment


Cause

This error could be a result to a corrupted installation export or a bad decryption passphrase. See the following links for information:https://github.com/attr-encrypted/attr_encrypted/issues/207

Resolution

Follow the steps to resolve this issue:

1.Power off the newly deployed OpsManager VM.

2. Power on the old OpsManager VM and login.

3. Click Admin (in upper right corner) and then click Settings.

4. Goto Decryption passphrase and enter a new New decryption passphrase.

5. Goto Export Installation Settings and re-export settings.

6. Power off old OpsManager VM.

7. Power on the new OpsManager with 1.12 OVA and re-import using config with new decryption passphrase.