Installation fails with the message, "Wrong response code: 500"
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Installation fails with the message, "Wrong response code: 500"

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Article ID: 293526

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Updated On:

Products

Operations Manager

Issue/Introduction

Symptoms:

When performing an installation or more likely, an upgrade of Pivotal Cloud Foundry® applying changes fails with the following error.

Uploading compiled package: Creating blob in inner blobstore: Making put command: Shelling out to bosh-blobstore-dav cli: Running command: 'bosh-blobstore-dav -c /var/vcap/bosh/etc/blobstore-dav.json put /var/vcap/data/tmp/bosh-platform-disk-TarballCompressor-CompressFilesInDir834155362 12020960-0f5f-4fbd-5a6d-a9de2dba6066', stdout: 'Error running app - Putting dav blob 12020960-0f5f-4fbd-5a6d-a9de2dba6066: Wrong response code: 500; body:500 Internal Server Error</pre>
<center>
<h1>500 Internal Server Error</h1>
</center><hr /><center>nginx</center>
<pre>

', stderr: '': exit status 1 (00:02:09)
 

 

Environment


Cause

This error occurs when the persistent disk of the Operations (Ops) Manager Director, also referred to as the micro bosh, runs out of disk space.

 

Resolution

The solution to this problem is to use Ops Manager to expand the size of the persistent disk associated with the Director. The following are the steps to perform this change:

  1. Login to the Ops Manager UI.
  2. Click on the Ops Manager Director tile.
  3. Click the Status tab. This will allow you to verify that the director is in fact out of persistent disk space. If it's with 5 or 10% of max, you should increase the available space.
  4. Click the "Settings" tab, then click the Resource Config screen.
  5. Edit the size of the persistent disk, it's the rightmost column. The default is 20G, we recommend doubling the size.
  6. Click "Save" to persist the change.
  7. Click "Apply Changes" and Bosh will resize the disk. This expands the disk so no data should be lost.