Pivotal Cloud Foundry Error, "Could not log in: Invalid tenant" when configuring Operations Manager IaaS"
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Pivotal Cloud Foundry Error, "Could not log in: Invalid tenant" when configuring Operations Manager IaaS"

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Article ID: 293467

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Updated On:

Products

Operations Manager

Issue/Introduction

Symptoms:

You received OpenStack errors when configuring Pivotal Cloud Foundry (PCF) Ops Manager and a subsequent following error with user authentication failures:

"Could not log in: Invalid tenant 'dev-pcf-north-01'"
 

 

Environment


Cause

Operations (Ops) Manager uses a library called Fog which only finds and displays the first project in the "OpenStack project list" that is assigned to that user. If Ops Manager was configured to use a tenant/project other than the first one, a later check in the Pivotal code fails which causes this error.


Analysis

Ops Manager on Pivotal Cloud Foundry will use the first project in the OpenStack project list. The user is authenticated with OpenStack, in this case, is probably a member of several projects as designed by the user for additional Pivotal Cloud Foundry installations.

Because the project configured in Ops Manager was a project listed further down on the list of the OpenStack projects, configuration failed.

Resolution

The workaround is to create a user assigned to a singular project only and use it to configure Pivotal Cloud Foundry. The error will be resolved by making the user a member of the same groups in both OpenStack and LDAP.